Windows 10 - Class not registered and urlmon.dll errors

Hey all, hopefully somebody there can help.

I have been getting the same errors over and over again on my desktop. I cannot access my start menu or Cortana. My task bar isn't always functional either. When I try to open up settings via task manager (ms-settings, try to open something recently downloaded through Firefox, or try to create a new profile, I get an error message saying Class not registered.

I have tried some solutions online, none have worked.

I have tried:
- scf /scannow on cmd.
- Using Powershell to run: Get-AppXPackage -AllUsers | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($_.InstallLocation)AppXManifest.xml"}
- Renaming and/or deleting my Tiledatalayer folder in AppData/Local

Also I keep getting this error stating "C:WINDOWSSYSTEM32urlmon.dll is either not designed to run on Windows or it contains an error." This message ends with "Error status 0xc000012f".

Has anybody come across this?

Thanks in advance.

HI and welcome to the blog

I don't believe you have posted this in the correct section, but they will move it for you.

If i'm correct URLMON.DLL is used by windows to go "online" and retrieve information (i'm not 100% sure).

The sfc /scannowcommand scans all protected system files and replaces incorrect versions with correct MS-versions.
When the scan was completed, did the tool indicate integrity violations?

Dit you recently install any new software? Maybe some software is holding it back, therefore I would suggest for you to do a clean boot.
With a Clean boot you will eliminate software conflicts that occur when you install a program or when you run a program in Windows.
Check if the issue persists when you do a clean boot, if not you can go from there and try to eliminate what's causing the issue.

How to perform a clean boot in Windows

Thank you for the reply, sorry I'm in the wrong area, I'm new here . I haven't installed anything new lately, but do have Windows updates set to automatic, big mistake there I'm now guessing.

Windows 10 - Class not registered and urlmon.dll errors